English (United Kingdom)
Jms Multi Site, formerly joomla multisite.
Create, share multiple joomla sites in few clicks !
Home FAQ/Change History Change history V1.3.x
Message
  • EU e-Privacy Directive

    This website uses cookies to manage authentication, navigation, and other functions. By using our website, you agree that we can place these types of cookies on your device.

    View e-Privacy Directive Documents

Change log Version 1.3.x
Version 1.3.35: Fix JomSocial ajax issue under Joomla 2.5 PDF Print E-mail

The Jms multisite for joomla 1.3.35 (All editions) fix the patch in "filesystem/path.php" under Joomla 2.5 in aim to fix and ajax issue with JomSocial (JPath::check Snooping....)

Last Updated on Friday, 03 October 2014 12:36
 
Version 1.3.34: Add aJmooL 1.5.28 compatibility PDF Print E-mail

Jms multisite for Joomla - All editions

  • Add sharing definition for Joomla 3.3
  • Add javascript "Joomla.submitbutton" call in the "check patches" to perform the "uninstall" verification and add display of an alert box to confirm the uninstallation of the patches.
  • Fix some PHP 5.4 Strict, warning and notice messages
  • Fix some J1.5/2.5/3.x API compatibilities (J2WinDB)

Compatibility with Legacy (1.5/2.5) extension for Joomla (2.5/3.x) - see :http://www.ajmool2win.com

aJmooL 1.5 is a fork of Joomla 1.5 that provides security fix and PHP 5.4 compatiblity for Joomla 1.5 and is designed to allow the Legacy 1.5 extension working with old Joomla 1.5 but also with new Joomla 2.5/3.3 login encryption

  • Add aJmooL 1.5 compatibility
    • Jms2WinFile::exists() static function detection
    • Jms2WinFolder::exists() static function detection
  • Add Legacy 1.5/2.5 for joomla compatibility
  • Open some internal JMS API to make them available for the Legacy 1.5 extension for joomla

 

Jms multisite for joomla - Full edition

- Add javascript "Joomla.submitbutton" to call the "local" submitbutton and perform field verification.

Bundled with Patches definition 1.3.30

  • Fix Geo-Localisation for the ICC when only the Country DB is present (City disabled).
    In this case, a message "Country Failed" is returned due to ICC that is uppercase instead of lowercase.
  • Add patch in "filesystem/path.php" under Joomla 2.5 to fix ajax issue with JomSocial (JPath::check Snooping....)
  • Update Wordpress patch for WP 3.8 and its new "wp-load.php" initialisation - Fix WP for Joomla 2.5+ compatibility
  • Add JMS Tools (install) definitions for :
    - Captcha - Play Thru
    - Dynamic 404
    - Fix JoomSEF
    - OS Property
  • Add Joomla 1.5 & aJmooL1.5 sharing definition for:
    - Update Hikashop to allow filtering the prices depending on the Site ID
  • Add Joomla 2.5 sharing definition for:
    - Update Hikashop to allow filtering the prices depending on the Site ID
  • > Add Joomla 3.3 sharing definition for:
    - OS Property
    - Update Hikashop to allow filtering the prices depending on the Site ID

=== aJmooL 1.5.x and Legacy 1.5/2.5 for Joomla 2.5/3.x compatibility ===

See http://www.ajmool2win.com

  • Update LibUser17 to ensure that user->_params is not null.
    (Mandatory when working with Legacy 1.5)
    See bugtracker #24879 that Joomla declined to fix.
    http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_id=8103&tracker_item_id=24879
  • Update the AdminIndex patch for aJmooL 1.5 compatiblity
  • Add Libraries/compat under J2.5 for J3.3 password algorithm verification
    See Joomla Pull Request #3695
    https://github.com/joomla/joomla-cms/pull/3695
  • Add LibCrypt25() under J2.5 to Add J3.3.x BCrypt compatibility
    See Joomla Pull Request #3688
    https://github.com/joomla/joomla-cms/pull/3688
  • Add libUserHlp25() under J2.5 to Add J3.3.x password verification compatibility
    See Joomla Pull Request #3691
    https://github.com/joomla/joomla-cms/pull/3691

- Bundled with Patches definition 1.3.29

  • Fix patch on the "filesystem/path.php" to also check the path against the Master Path Root
  • Add Joomla 3.3 sharing definition that is a copy of the Joomla 3.2 one
Last Updated on Wednesday, 06 August 2014 13:12
 
Version 1.3.33: Add Joomla 3.3 compatibility PDF Print E-mail

Jms multisite for joomla version 1.3.33 - All editions

  • Add Joomla 3.3 compatibility

 

Bundled with Patches definition 1.3.28

  • Add JMS Tools (install) definitions for :
    - CrowdFunding
    - CrowdFunding Finance
    - Perfect Popup Box
  • Add Joomla 3.2 sharing definition for:
    - CrowdFunding (Geo data)

 

 
Version 1.3.32: Add definition of Agora Pro, jVoteSystem PDF Print E-mail

Jms multisite for joomla All editions

- Under J3.2, Verify that old JSimpleXML is not already installed by other extensions (ie. JVital plugin used by agora-pro) to avoid duplicated class definition that leads to a PHP Fatal error.
It is assumed that when the JSimpleXML class is present that this is the original joomla one.
- Fix the packaging concerning the "the uninstall of a template" advertised in version 1.3.29 but not correctly package (The fix was missing in the distribution).
- Update the memory limit verification to add the GB in addition to existing MB and KB

Maintenance menu

- When there is no legacy mode selected, now by default, the verification of a "Create Table" also verify all the field.
In the previous version, only the verification that the table exists was performed without structure verification.
The new default behavior is equivalent to "fix table".

Bundled with Patches definition 1.3.27

  • Add JMS Tools (install) definitions for :
    - Agora Pro
    - Akeeba DocImport
    - Akeeba Release System
    - Akeeba Ticket System
    - jVoteSystem
    - Skyline Advanced Poll
  • Add Joomla 3.2 sharing definition for:
    - Akeeba DocImport
    - Akeeba Release System

 

Last Updated on Friday, 04 April 2014 13:31
 
Version 1.3.31: Improve compatibility with Joomla 3.2 in the front-end PDF Print E-mail

Jms multisites for joomla version 1.3.31 "Full editions"

  • Improve the compatibiliy with Joomla 3.2 when creating (or listing) the website from the front-end.
    Under Joomla 3.x, a PHP Fatal error may occurs due to functions that are renamed  in the core of Joomla

Jms multisites for joomla version 1.3.31 "All edition"

  • Update the PHP memory limited present in the Tool menu to take in account the unlimited memory (-1)
Last Updated on Wednesday, 26 March 2014 16:15
 


Page 10 of 18
2Win, Multisite(s) are trademarks of Edwin2Win.
Joomla